通达信自动画通道线主图指标公式

发布时间:2021-05-15 发表于话题:通达信趋势通道画线公式 点击:87 当前位置:财神股票资讯网 动漫 通达信自动画通道线主图指标公式 手机阅读

N:=33;
UR:=6;
LR:=6;
TC1:=IF(H=HHV(H,8*UR),H,DRAWNULL);
TC2:=CONST(BARSLAST(TC1=H))+1;
UPPER:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
BC1:=IF(L=LLV(L,8*LR),L,DRAWNULL);
BC2:=CONST(BARSLAST(BC1=L))+1;
LOWER:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
LP:=CURRBARSCOUNTTC2,LP,HP),LOWER,UPPER,0,0),COLOR628962;{左侧竖线}
NOD:=(IF(TC2>BC2,TC2,BC2)-IF(TC2>BC2,BC2,TC2));{用时}
LR1:=FORCAST(C,NOD+1);
NP:IF(CURRBARSCOUNTTC2,DBL,DBH)-1;
LRL:=IF(NP>FP,FP+AD/NOD*BSP,FP-AD/NOD*BSP);
AT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND H>LRL,H,LRL);
AT2:=HHV(AT1-LRL,MAX(BC2,TC2));
AT3:=CONST(BARSLAST(AT1-LRL=AT2));
AT4:=CONST(IF(AT3=0,H,REF(H,AT3)));
AT5:=CONST(IF(AT3=0,AT1-LRL,REF(AT1-LRL,AT3)));
ATL:=LRL+AT5;
UT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND L=MIN(BC2,TC2)-10,ATL,CONST(REF(ATL,MIN(BC2,TC2)-11)));
RL:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,UTL,CONST(REF(UTL,MIN(BC2,TC2)-11)));
{IF(NP>FP,IF(LRL=RL,LRL,DRAWNULL)),COLORRED;}{中轨画线}
IF(NP>FP,IF(ATL=RL,ATL,DRAWNULL)),COLORYELLOW;{上轨画线}
IF(NP>FP,IF(UTL=RL,UTL,DRAWNULL)),COLORFFFFFF;{下轨画线};

 

本文来源:https://www.thyysj.com/info/472660.html

标签组:[动画

相关APP下载

热门话题

动漫推荐文章

动漫热门文章